Advanced Programming
Handout 8

Drawing Regions
(SOE Chapter 10)



Pictures

m Drawing Pictures
m Pictures are composed of Regions (which are
composed of shapes)

m Pictures add color and layering

= Region Color Region

| Picture "Over Picture
| EmptyPic

deriving Show

data Picture



Digression on Importing

m We need to use SOEGraphics for drawing things on the screen,
but SOEGraphics has its own Region datatype, leading to a name
clash when we try to import both SOEGraphics and our Region
module.

m We can work around this as follows:

import SOEGraphics hiding (Region)
import gqualified SOEGraphics as G (Region)

m The effect of these declarations is that all the names from
SOEGraphics except Region can be used in unqualified form, and
we can say G.Region to refer to the one from SOEGraphics.



Recall the Region Datatype

data Region =

Shape Shape -- primitive shape
| Translate Vector Region -- translated region
| Scale Vector Region -—- scaled region
| Complement Region -- inverse of a region
| Region "Union Region -- union of regions
| Region "Intersect Region -- intersection of regions
| Empty

= How do we draw things like the intersection of two regions, or the
complement of a region? These are hard to do efficiently. Fortunately,
the G.Region interface uses lower-level support to do this for us.



G.Region

m The G.Region datatype
interfaces more directly to the
underlying hardware.

It is essentially a two-
dimensional array or “bit-

map”, storing a binary value
:T for each pixel in the window.




Efficient Bit-Map Operations

m There is efficient low-level support for combining bit-maps using
a variety of operators. For example, for union:

¥ - £

m  Making these operations fast requires detailed control over data
layout in memory -- a job for a lower-level language. This part of
the SOEGraphics module is therefore just a “wrapper” for an
external library (probably written in C).



G.Region Interface

createRectangle
createEllipse
createPolygon

andRegion
orRegion
xorRegion
diffRegion
deleteRegion

drawRegion

>

(—

Point -> Point -> IO G.Region
Point -> Point -> IO G.Region
[Point]

G.
.Region
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@

Region

.Region
.Region
.Region

.Region

G.Region
G.Region
G.Region
G.Region
I0 ()

Graphic

-> I0 G.Region

-> I0 G.Region
-> I0 G.Region
-> I0 G.Region
-> I0 G.Region

These functions are defined in the SOEGraphics library module.



Drawing G.Region

m To render things involving intersections and unions quickly, we
perform these calculations in a G.Region, then turn the G.Region

into a graphic object, and then use the machinery we have seen in
earlier chapters to display the object.

drawRegionInWindow ::
Window -> Color -> Region -> IO ()

drawRegionInWindow w ¢ r =
drawInWindow w

(withColor c¢ (drawRegion (regionToGRegion r)))

m To finish this off, we still need to define regionToGRegion.

m But first let’s complete the big picture by writing the (straightforward)
function that uses drawRegionInWwindow to draw Pictures.



Drawing Pictures

m Pictures combine multiple regions into one big picture. They provide
a mechanism for placing one sub-picture on top of another.

drawPic :: Window -> Picture -> IO ()

drawPic w (Region c r) = drawRegionInWindow w ¢ r
drawPic w (pl Over p2) = do drawPic w p2

drawPic w pl
drawPic w EmptyPic = return ()

m Note that p2 is drawn before p1l, since we want pl to appear
“over’ p2.

Now back to the code for rendering Regions as G.Regions...



Turning a Region
into a G.Region

Let’s first experiment with a simplified variant of the problem to illustrate
an efficiency issue...

data NewRegion = Rect Side Side

regToNReg :: Region -> NewRegion
regToNReg (Shape (Rectangle sx sy))
= Rect sx sy
regToNReg (Scale (x,y) r)
= regToNReg (scaleReg (x,y) r)
where scaleReg (x,y) (Shape (Rectangle sx sy))
= Shape (Rectangle (x*sx) (y*sy))
scaleReg (x,y) (Scale s r)
= Scale s (scaleReg (x,y) r)



A Problem

m Consider

(Scale (x1,yl)
(Scale (x2,y2)
(Scale (x3,y3)
(Shape (Rectangle sx sy))
)))

m If the scaling is nlevels deep, how many traversals does
regToNReg perform over the Region tree?



We've Seen This Before

m  We have encountered this problem before in a different setting.
Recall the naive definition of reverse:

[]

(reverse xs) ++ [x]

reverse |[]
reverse (x:xs)

S

where [] ++ zs Z
y : (ys ++ zs)

(y:ys) ++ zs

m How did we solve this? We used an extra accumulating
parameter:

reverse xs = loop xs []
where loop [] zs = ZSs
loop (x:xs) zs = loop xs (x:zs)

m We can do the same thing for Regions.

N.b.: A good compiler (like
GHC) reallywillimplement
this function call as a jump!




Accumulating the Scaling Factor

regToNReg2 :: Region -> NewRegion
regToNReg2 r = rToNR (1,1) r
where rToNR :: (Float,Float) -> Region -> NewRegion

rToNR (x1,yl) (Shape (Rectangle sx sy))
= Rect (xl*sx) (yl*sy)

rToNR (x1,yl) (Scale (x2,y2) r)
= rToNR (x1*x2,yl*y2) r

m To solve our original problem, repeat this for all the constructors of
Region (notjust Shape and Scale) and use G.Region instead of
NewRegion. We also need to handle translation as well as scaling.



Final Version

regToGReg :: Vector -> Vector -> Region -> G.Region
regToGReg loc sca (Shape s)
= shapeToGRegion loc sca s
regToGReg loc (sx,sy) (Scale (u,v) r)
= regToGReg loc (sx*u, sy*v) r
regToGReg (1lx,ly) (sx,sy) (Translate (u,v) r)
= regToGReg (lx+u*sx, ly+v¥*sy) sca r
regToGReg loc sca Empty
= createRectangle (0,0) (0,0)
regToGReg loc sca (rl "Union r2)
= let grl = regToGReg loc sca rl
gr2 = regToGReg loc sca r2
in orRegion grl gr2

To finish, we need to write similar clauses for Intersect,
Complement etc. and define
shapeToGRegion :: Vector -> Vector -> Shape -> G.Region



A Matter of Style

= While the function on the previous page does the job
correctly, there are several stylistic issues that could
make it more readable and understandable.

m For one thing, the style of defining a function by
patterns becomes cluttered when there are many
parameters (other than the one which has the patterns).

m For another, the pattern of explicitly allocating and
deallocating (bit-map) G.Region’s will be repeated in
cases for intersection and for complement, so we
should abstract it, and give it a name.



Abstracting Out a Common Pattern

primGReg loc sca rl r2 op
= let grl = regToGReg loc sca rl
gr2 = regToGReg loc sca r2
in op grl gr2



Definition by cases with a Case
EXxpression

regToGReg :: Vector -> Vector -> Region -> G.Region

regToGReg (loc@(1lx,ly))

case shape of
Shape s ->
Translate (u,v) r ->

Scale (u,v) r ->
Empty ->
rl "Union r2 ->

rl "Intersect’ r2 ->

Complement r ->

(sca@(sx,sy)) shape =

shapeToGRegion loc sca s
regToGReg (lx+u*sx,ly+tu*sy) sca r
regToGReg loc (sx*u, sy*v) r
createRectangle (0,0) (0,0)
primGReg loc sca rl r2 orRegion
primGReg loc sca rl r2 andRegion

primGReg loc sca winRect r diffRegion

regionToGRegion :: Region -> G.Region

regionToGRegion r = regToGReg (0,0) (1,1) r



Drawing Pictures

draw :: Picture -> IO ()
draw p = runGraphics (
do w <- openWindow "Region Test" (xWin,yWin)
drawPic w p
spaceClose w



A Better Definition

($) :: (a->b) -> a -> b
f ($) x=f£f x

draw :: Picture -> IO ()
draw p = runGraphics $
do w <- openWindow "Region Test" (xWin,yWin)
drawPic w p
spaceClose w

In effect, we’ve introduced a second syntax for
application, with lower precedence than the standard one



Some Sample Regions

rl = Shape (Rectangle 3 2)
r2 = Shape (Ellipse 1 1.5)
r3 = Shape (RtTriangle 3 2)
r4 = Shape (Polygon [(-2.5,2.5), (-3.0,0),

(-1.7,-1.0),
(-1.1,0.2), (-1.5,2.0)] )



Sample Pictures

reg = r3 "Union -- RtTriangle
(rl "Intersect’ -- Rectangle
Complement r2 "Union -- Ellipse
r4) -- Polygon

[ Region Test

picl = Region Cyan reg
Mainl = draw picl




More Pictures

reg2 = let circle = Shape (Ellipse 0.5 0.5)
square = Shape (Rectangle 1 1)
in (Scale (2,2) circle)
"Union  (Translate (2,1) square)
"Union  (Translate (-2,0) square)
pic2 = Region Yellow reg2 SR
main2 = draw pic2




Another Picture

pic3 = pic2 "Over picl

main3 = draw pic3




Separating Computation From
Action

oneCircle = Shape (Ellipse 1 1)
manyCircles = [ Translate (x,0) oneCircle | x <- [0,2..] ]
fiveCircles = foldr Union Empty (take 5 manyCircles)
pic4 = Region Magenta R
(Scale (0.25,0.25)

fiveCircles)
maind4d = draw pic4




Ordering Pictures

pictTolList :: Picture -> [ (Color,Region)]
pictToList EmptyPic = [1]
pictToList (Region c r) = [(c,xr)]

pictTolist (pl "Over p2)
= pictTolist pl ++ pictTolList p2

Lists the Regions in a Picture from top to bottom.

(Note that this is possible because Picture is a datatype
that can be analyzed. Would not work with, e.g., a
characteristic function representation.)



A Suggestive Analogy

pictTolList EmptyPic = []
pictToList (Region ¢ r) = [(c,r)]
pictTolist (pl Over p2) = pictTolist pl ++ pictTolList p2

drawPic w (Region c r) = drawRegionInWindow w c r
drawPic w (pl "Over p2)

do drawPic w p2
drawPic w pl

drawPic w EmptyPic return ()

We’'ll have (much) more
to say about this later...



Pictures that React

m Goal: Find the topmost Region in a Picture that “covers” the
position of the mouse when the left button is clicked.

first Region that contains the mouse position.

adjust :: [(Color,Region)] -> Vertex ->
(Maybe (Color,Region), [(Color,Region)])

adjust [] p = (Nothing, [])
adjust ((c,r):regs) p =
if r "containsR™ p
then (Just (c,r), regs)
else let (hit, rs) = adjust regs p
in (hit, (c,r) : rs)

Implementation: Search the picture (represented as a list) for the

Then (just for fun) re-arrange the list, bringing that one to the top.



Doing it Non-recursively

From the Prelude:
break:: (a -> Bool) -> [a] -> ([al, [a])

For example:
break even [1,3,5,4,7,6,12] = ([1,3,5]1,[4,7,6,12])

So:
adjust2 regs p
= cige (break (\(_,r) -> r "containsR p) regs)
o
(top,hit:rest) -> (Just hit, topt++rest)
(_,[1) -> (Nothing, regs)



Putting it all Together

loop :: Window -> [ (Color,Region)] -> IO ()
loop w regs =
do clearWindow w

sequence [ drawRegionInWindow w c r |
(c,r) <- reverse regs ]

(x,y) <- getlBP w
case (adjust regs (pixelToInch (x - xWin2),
pixelToInch (yWin2 - y) )) of
(Nothing, ) -> closeWindow w
(Just hit, newRegs) -> loop w (hit : newRegs)

draw2 :: Picture -> IO ()
draw2 pic = runGraphics $
do w <- openWindow "Picture demo" (xWin,yWin)
loop w (pictTolist pic)



A Matter of Style, Redux

loop2 w regs
= do clearWindow w
sequence [ drawRegionInWindow w c r |
(c,r) <- reverse regs ]
(x,y) <- getlBP w
let (px,py) = (pixelToInch (x-xWinZ2),
pixelToInch (yWin2-y))

let testHit (_,r) = r "containsR (px,py)

case (break testHit regs) of
(_,[1) -> closeWindow w
(top,hit:bot) -> loop w (hit: (top++bot))

draw3 pic = runGraphics $
do w <- openWindow "Picture demo" (xWin,yWin)
loop2 w (pictTolist pic)



Try it Out

pl,p2,p3,p4 :: Picture
pl = Region Magenta rl
p2 = Region Cyan r2

p3 = Region Green r3
p4 = Region Yellow r4

pic :: Picture
pic = foldl Over EmptyPic [pl,p2,p3,p4]
main = draw3 pic



Extra slides...



Implementing
ShapeToGRegion

shapeToGRegion
:: Vector -> Vector -> Shape -> IO G.Region
shapeToGRegion (1lx,ly) (sx,sy) (Rectangle sl s2)
= createRectangle (trans(-sl/2,-s2/2)) (trans (sl/2,s2/2))
where trans (x,y) = ( xWin2 + inchToPixel (lx+x*sx),
yWin2 - inchToPixel (ly+y*sy) )

sl

s1/ S2/2 |s2

( XWin,
yWin )




The Ellipse Case

shapeToGRegion (1lx,ly) (sx,sy) (Ellipse rl r2)
= createEllipse (trans (-rl,-r2)) (trans ( rl, r2))
where trans (x,y) =
( xWin2 + inchToPixel (lx+x*sx),

yWin2 - inchToPixel (ly+y*sy) )

r

fllli
[k




Polygon and RtTriangle

shapeToGRegion (lx,ly) (sx,sy) (Polygon pts)
= createPolygon (map trans pts)
where trans (x,y) =
( xWin2 + inchToPixel (lx+x*sx),
yWin2 - inchToPixel (ly+y*sy) )

shapeToGRegion (1lx,ly) (sx,sy) (RtTriangle sl s2)
= createPolygon (map trans [(0,0), (s1,0), (0,s2)])
where trans (x,y) =
( xWin2 + inchToPixel (lx+x*sx),
yWin2 - inchToPixel (ly+y*sy) )



A Matter of Style, 2

shapeToGRegion (1lx,ly) (sx,sy) s = case s of
Rectangle sl s2 -> createRectangle (trans (-sl/2,-s2/2))
(trans ( sl/2, s2/2))

Ellipse rl r2 -> createEllipse (trans (-rl,-r2))
(trans ( rl, r2))
Polygon pts -> createPolygon (map trans pts)

RtTriangle sl s2 -> createPolygon
(map trans [(0,0), (s1,0),(0,s2)])
where trans (x,y) = ( xWin2 + inchToPixel (1lx+x*sx),
yWin2 - inchToPixel (ly+y*sy) )

shapeToGRegion has the same problems as regToGReg
m The extra parameters obscure the pattern matching.
m There is a repeated pattern; we should give it a name.



