On my query as to what to call the components T1,..,Tn
in a type
T = T1 -> (T2 -> (... (Tn -> e)..))
the majority vote was for "argument types". This is a precise
notation but it is a bit too long for my particular purpose, which
involved incorporating it into a notation for the argument-types of
a subtype T of another type S, and "subargument-types" or similar
seems a bit of a mouthful.
Fred Linton suggested "Premise" (or "premiss"), which
is shorter and makes "subpremise" which is a tolerable length, so
have decided to adopt that.
There seems to be no standard notation. The alternatives were:
Thanks very much to everyone who replied. Roger Hindley