Java Test Applets

This page displays applets that can be run by Java versions 1.0 through 1.7, plus Swing (9 applets in all). You should see a colorful display for each of these applets below. A grey or empty square indicates that your version of Java needs to be upgraded.

If you don't see anything below this paragraph, or all the squares are a uniform gray, either you don't have any version of Java, or (more likely) your browser is "protecting" you from running applets. Tweaking your security settings may help.

Java 1.0
>
Java 1.1
Java 1.2
Java 1.3
Java 1.4
Java 1.5 (= Java 5)
Java 6.0 (= Java 1.6)
Java 7.0 (= Java 1.7)
Java with Swing